hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17908) Upgrade guava
Date Fri, 23 Jun 2017 08:19:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17908?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16060564#comment-16060564
] 

Hadoop QA commented on HBASE-17908:
-----------------------------------

| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue} 0m 0s {color} | {color:blue}
Docker mode activated. {color} |
| {color:red}-1{color} | {color:red} patch {color} | {color:red} 0m 6s {color} | {color:red}
HBASE-17908 does not apply to master. Rebase required? Wrong Branch? See https://yetus.apache.org/documentation/0.3.0/precommit-patchnames
for help. {color} |
\\
\\
|| Subsystem || Report/Notes ||
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12874215/HBASE-17908.master.002.patch
|
| JIRA Issue | HBASE-17908 |
| Console output | https://builds.apache.org/job/PreCommit-HBASE-Build/7301/console |
| Powered by | Apache Yetus 0.3.0   http://yetus.apache.org |


This message was automatically generated.



> Upgrade guava
> -------------
>
>                 Key: HBASE-17908
>                 URL: https://issues.apache.org/jira/browse/HBASE-17908
>             Project: HBase
>          Issue Type: Sub-task
>          Components: dependencies
>            Reporter: Balazs Meszaros
>            Assignee: stack
>            Priority: Critical
>             Fix For: 2.0.0
>
>         Attachments: HBASE-17908.master.001.patch, HBASE-17908.master.002.patch
>
>
> Currently we are using guava 12.0.1, but the latest version is 21.0. Upgrading guava
is always a hassle because it is not always backward compatible with itself.
> Currently I think there are to approaches:
> 1. Upgrade guava to the newest version (21.0) and shade it.
> 2. Upgrade guava to a version which does not break or builds (15.0).
> If we can update it, some dependencies should be removed: commons-collections, commons-codec,
...



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message