hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry He (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16242) Upgrade Avro
Date Fri, 16 Jun 2017 20:12:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16242?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16052338#comment-16052338
] 

Jerry He commented on HBASE-16242:
----------------------------------

I think it should be safe for us to upgrade to Avro 1.7.7 on HBase 2?  That will resolve HBASE-16246
as well.
Then we will be consistent with Spark 1.x and 2.x.  We will be a little ahead of Hadoop in
the 2.7.x line, but will be good with 2.8.x based on HADOOP-12527.  (But again, when Hadoop
3 comes along, we are out of sync again.)
FWIW, Hive has been on Avro 1.7.7 for a long while.  


> Upgrade Avro
> ------------
>
>                 Key: HBASE-16242
>                 URL: https://issues.apache.org/jira/browse/HBASE-16242
>             Project: HBase
>          Issue Type: Task
>          Components: dependencies
>            Reporter: Ben McCann
>
> I'd like to see Avro upgraded to 1.8.1 or at the very least 1.7.7



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message