hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-16196) Update jruby to a newer version.
Date Mon, 05 Jun 2017 16:08:04 GMT

     [ https://issues.apache.org/jira/browse/HBASE-16196?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Sean Busbey updated HBASE-16196:
       Resolution: Fixed
     Hadoop Flags: Incompatible change
    Fix Version/s:     (was: 1.5.0)
     Release Note: 
The bundled JRuby 1.6.8 has been updated to version The represents a change from
Ruby 1.8 to Ruby 2.3.3, which introduces non-compatible language changes for user scripts.

This JRuby version update required an update to joni-2.1.11 and jcodings-1.0.18, used for
regular expression matching, as well as several transitive dependency updates that should
not be user-visible.
           Status: Resolved  (was: Patch Available)

> Update jruby to a newer version.
> --------------------------------
>                 Key: HBASE-16196
>                 URL: https://issues.apache.org/jira/browse/HBASE-16196
>             Project: HBase
>          Issue Type: Bug
>          Components: dependencies, shell
>            Reporter: Elliott Clark
>            Assignee: Mike Drob
>            Priority: Critical
>             Fix For: 2.0.0
>         Attachments: 0001-Update-to-JRuby-, hbase-16196.branch-1.patch,
HBASE-16196-branch-1.v9.patch, hbase-16196.v2.branch-1.patch, hbase-16196.v3.branch-1.patch,
hbase-16196.v4.branch-1.patch, HBASE-16196.v5.patch, HBASE-16196.v6.patch, HBASE-16196.v7.patch,
HBASE-16196.v8.patch, HBASE-16196.v9.patch
> Ruby 1.8.7 is no longer maintained.
> The TTY library in the old jruby is bad. The newer one is less bad.
> Since this is only a dependency on the hbase-shell module and not on hbase-client or
hbase-server this should be a pretty simple thing that doesn't have any backwards compat issues.

This message was sent by Atlassian JIRA

View raw message