hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-14998) Unify synchronous and asynchronous methods in Admin and cleanup
Date Fri, 30 Jun 2017 11:17:00 GMT

     [ https://issues.apache.org/jira/browse/HBASE-14998?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-14998:
--------------------------
    Priority: Critical  (was: Major)

> Unify synchronous and asynchronous methods in Admin and cleanup
> ---------------------------------------------------------------
>
>                 Key: HBASE-14998
>                 URL: https://issues.apache.org/jira/browse/HBASE-14998
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Priority: Critical
>             Fix For: 2.0.0
>
>
> Admin has a bunch of methods, some are asnyc, some are sync. Needs some unification in
method naming, and method signatures. 
>  - We use modify and alter interchangeably. Pick one and stick with it (modifyTable(),
versus getAlterStatus()). Shell uses {{alter}}. 
>  - Remove getAlterStatus(), should not be needed. 
>  - remove already deprecated methods 
>  -  isTableAvailable(TableName tableName, byte[][] splitKeys) should be removed. 
>  - Consistently use Aysnc as a prefix for all async methods. 
>  - Other ideas? 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message