hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dima Spivak (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-18020) Update API Compliance Checker to Incorporate Improvements Done in Hadoop
Date Thu, 11 May 2017 22:30:04 GMT

    [ https://issues.apache.org/jira/browse/HBASE-18020?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16007307#comment-16007307
] 

Dima Spivak commented on HBASE-18020:
-------------------------------------

I guess what I'm saying is that the effort to convert this patch from Python 2 to Python 3
will be minimal, but by doing so, you'll be able to make certain assumptions that will aid
significantly in readability. For example, {{argparse}} is part of the Python 3 standard library,
so there'd be no need to worry about not being able to import it. Furthermore, using {{os.path}}
is gross and awful and exactly why Python 3 has {{pathlib}}. Just my two cents.

> Update API Compliance Checker to Incorporate Improvements Done in Hadoop
> ------------------------------------------------------------------------
>
>                 Key: HBASE-18020
>                 URL: https://issues.apache.org/jira/browse/HBASE-18020
>             Project: HBase
>          Issue Type: Improvement
>          Components: API, community
>            Reporter: Alex Leblang
>            Assignee: Alex Leblang
>             Fix For: 2.0.0
>
>         Attachments: HBASE-18020.0.patch
>
>
> Recently the Hadoop community has made a number of improvements in their api compliance
checker based on feedback from the hbase and kudu community. We should adopt these changes
ourselves.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message