hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-17514) Warn when Thrift Server 1 is configured for proxy users but not the HTTP transport
Date Mon, 24 Apr 2017 20:55:04 GMT

     [ https://issues.apache.org/jira/browse/HBASE-17514?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Busbey updated HBASE-17514:
--------------------------------
      Resolution: Fixed
    Release Note: If users of the Thrift 1 Server enable proxy user support without enabling
the prerequisite HTTP transport, we now log a WARN message about the mismatch.
          Status: Resolved  (was: Patch Available)

> Warn when Thrift Server 1 is configured for proxy users but not the HTTP transport
> ----------------------------------------------------------------------------------
>
>                 Key: HBASE-17514
>                 URL: https://issues.apache.org/jira/browse/HBASE-17514
>             Project: HBase
>          Issue Type: Improvement
>          Components: Thrift, Usability
>            Reporter: Sean Busbey
>            Assignee: lv zehui
>            Priority: Minor
>              Labels: beginner
>             Fix For: 2.0.0, 1.4.0, 1.2.6, 1.3.2, 1.1.11
>
>         Attachments: HBASE-17514.master.001.patch
>
>
> The config {{hbase.thrift.support.proxyuser}} is ignored if the Thrift Server 1 isn't
configured to use an HTTP transport with {{hbase.regionserver.thrift.http}}.
> We should emit a warning if our configs request proxy user support but don't specify
that HTTP should be used for the transport.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message