hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15583) Any HTableDescriptor we give out should be immutable
Date Mon, 17 Apr 2017 03:41:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15970642#comment-15970642
] 

Chia-Ping Tsai commented on HBASE-15583:
----------------------------------------

bq. We stuck w/ API like this? HTableDescriptor[] listTables() throws IOException; ?
I prefer the collection to array, but the API is public. Deprecate it?

bq. CompletableFuture<HTableDescriptor[]> listTables();, to CompletableFuture<TableDescriptor[]>
listTables();
copy that.


> Any HTableDescriptor we give out should be immutable
> ----------------------------------------------------
>
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Assignee: Chia-Ping Tsai
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15583.v0.patch, HBASE-15583.v1.patch, HBASE-15583.v2.patch
>
>
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message