hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15583) Any HTableDescriptor we give out should be immutable
Date Sat, 15 Apr 2017 22:38:42 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15970180#comment-15970180

stack commented on HBASE-15583:

I like the [~enis] suggestion.

Skimmed. Nice clean-up [~chia7712]. Looks great.

We stuck w/ API like this? HTableDescriptor[] listTables() throws IOException;  ?

Could change it in the Async version at least since that is new to 2.0? i.e. change this CompletableFuture<HTableDescriptor[]>
listTables();, to CompletableFuture<TableDescriptor[]> listTables();

> Any HTableDescriptor we give out should be immutable
> ----------------------------------------------------
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Assignee: Chia-Ping Tsai
>            Priority: Minor
>             Fix For: 2.0.0
>         Attachments: HBASE-15583.v0.patch, HBASE-15583.v1.patch, HBASE-15583.v2.patch
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 

This message was sent by Atlassian JIRA

View raw message