hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15583) Any HTableDescriptor we give out should be immutable
Date Thu, 13 Apr 2017 10:40:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15967390#comment-15967390
] 

Enis Soztutar commented on HBASE-15583:
---------------------------------------

An alternate proposal is doing something like this: 
 - Introduce {{TableDescriptor}} class. HTD will extend TableDescriptor.
 - TableDescriptor will contain all of the read-only methods from HTD. 
 - Deprecate HTD to be removed in 3.0.
 - Remove UnmodifyableTD. 
 - TableDescriptor will be read only. 
 - Introduce TableDescriptorBuilder for modifying TableDescriptors. You would set the fields,
and call build() to get the TD. 
 - Do the same thing for ColumnDescriptor as well. 

> Any HTableDescriptor we give out should be immutable
> ----------------------------------------------------
>
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Assignee: Chia-Ping Tsai
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15583.v0.patch, HBASE-15583.v1.patch
>
>
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message