hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6580) Deprecate HTablePool in favor of HConnection.getTable(...)
Date Mon, 17 Apr 2017 06:14:42 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6580?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15970716#comment-15970716
] 

Hudson commented on HBASE-6580:
-------------------------------

FAILURE: Integrated in Jenkins build HBase-Trunk_matrix #2873 (See [https://builds.apache.org/job/HBase-Trunk_matrix/2873/])
HBASE-17903 Corrected the alias for the link of HBASE-6580 (chia7712: rev 918aa4655c4109159f27b6d78460bd3681c11f06)
* (edit) src/main/asciidoc/_chapters/architecture.adoc


> Deprecate HTablePool in favor of HConnection.getTable(...)
> ----------------------------------------------------------
>
>                 Key: HBASE-6580
>                 URL: https://issues.apache.org/jira/browse/HBASE-6580
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 0.94.6, 0.95.0
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>             Fix For: 0.98.0, 0.95.2, 0.94.11
>
>         Attachments: 6580-0.94.txt, 6580-0.94-v2.txt, 6580-trunk.txt, 6580-trunk-v2.txt,
6580-trunk-v3.txt, 6580-trunk-v4.txt, 6580-trunk-v5.txt, 6580-trunk-v6.txt, HBASE-6580_v1.patch,
HBASE-6580_v2.patch
>
>
> Update:
> I now propose deprecating HTablePool and instead introduce a getTable method on HConnection
and allow HConnection to manage the ThreadPool.
> Initial proposal:
> Here I propose a very simple TablePool.
> It could be called LightHTablePool (or something - if you have a better name).
> Internally it would maintain an HConnection and an Executor service and each invocation
of getTable(...) would create a new HTable and close() would just close it.
> In testing I find this more light weight than HTablePool and easier to monitor in terms
of resources used.
> It would hardly be more than a few dozen lines of code.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message