hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Yuan Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17764) Solve TestMultiSlaveReplication flakiness
Date Thu, 09 Mar 2017 21:24:37 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17764?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15903872#comment-15903872
] 

Stephen Yuan Jiang commented on HBASE-17764:
--------------------------------------------

Another note: in HBASE-16598 (at this time, only commit in master branch), the TestMultiSlaveReplication#testZKLockCleaner
was removed; therefore, not problem in master branch.

> Solve TestMultiSlaveReplication flakiness 
> ------------------------------------------
>
>                 Key: HBASE-17764
>                 URL: https://issues.apache.org/jira/browse/HBASE-17764
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>            Reporter: Stephen Yuan Jiang
>            Assignee: Stephen Yuan Jiang
>            Priority: Minor
>         Attachments: HBASE-17764.v1-branch-1.patch
>
>
> When I doing testing for a feature I am working on, the TestMultiSlaveReplication test
was flaky.  TestMultiSlaveReplication#testMultiSlaveReplication would always pass when running
alone; however, it would fail occasionally when running with the suite (the other test TestMultiSlaveReplication#testZKLockCleaner
always run first and I suspect that it withhold some zookeeper resource, which caused the
problem).  
> After I set start and shutdown zk cluster before and after each test, I no longer see
the problem.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message