hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17576) [C++] Implement request retry mechanism over RPC for Multi calls.
Date Mon, 06 Mar 2017 23:16:32 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17576?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15898352#comment-15898352

Enis Soztutar commented on HBASE-17576:

- Some of these should be {{int32_t}} or {{size_t}}:
+  Action(std::shared_ptr<Row> action, int original_index)
+int hbase::MultiAction::Size() const {
+  int size = 0;
probably you were not able to run {{make lint}} yet. We can do that close to commit. 
- Remove these:
+  // std::string row_ = "";
+  // const std::string& Row() const;
+// const std::string &Get::Row() const { return row_; }
and also other commented out code. 
- We should be using only 1 way to name files. In the current code base, there are both {{foo-bar.cc}}
and {{foo_bar.cc}} used. Let's just stick to using {{foo-bar.cc}} for all of the new files.
For example, {{region_result.h}} should be {{region-result.h}}, etc. I'll fix this in a different
jira in the existing code base. 
- Returning a {{const shared_ptr<T> &}} does not make sense to me. Maybe you should
return just {{const Row&}} here: 
+  const std::shared_ptr<Row> &GetAction() { return action_; }
- We do not need this class: {{AsyncRpcRetryingBatchCallerFactory}}. Instead the code should
go inside the {{AsyncRpcRetryingCallerFactory}} class. We want {{AsyncRpcRetryingCallerFactory::Batch()}}
call similar to the {{::Single()}} call. 
- In class {{BatchCallerBuilder}}, you can use the C++ conventions to name the methods like
SetActions, SetTable, etc like actions() tables(), etc. Look at the {{SingleRequestCallerBuilder}}.

To be continued. 

> [C++] Implement request retry mechanism over RPC for Multi calls.
> -----------------------------------------------------------------
>                 Key: HBASE-17576
>                 URL: https://issues.apache.org/jira/browse/HBASE-17576
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Sudeep Sunthankar
>            Assignee: Sudeep Sunthankar
>         Attachments: HBASE-17576.HBASE-14850.v1.patch, HBASE-17576.HBASE-14850.v2.patch,
HBASE-17576.HBASE-14850.v3.patch, HBASE-17576.HBASE-14850.v4.patch, HBASE-17576.HBASE-14850.v5.patch
> This work is based on top of HBASE-17465. Multi Calls will be based on this.

This message was sent by Atlassian JIRA

View raw message