hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15583) Discuss mutable vs immutable HTableDescriptor
Date Mon, 20 Mar 2017 04:21:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15932146#comment-15932146
] 

stack commented on HBASE-15583:
-------------------------------

[~gliptak] makes a good point that we should be consistent.

I'd think that any HTD we give out should be immutable. We do not want to give impression
that modifying a HTD means the schema is changed throughout the system. I'd think you'd create
a new HTD from the immutable one (I like the idea of naming it immutable rather than modifiable
(or modifyable which I think I might have done mistakenly?)

> Discuss mutable vs immutable HTableDescriptor
> ---------------------------------------------
>
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Priority: Minor
>              Labels: beginner
>             Fix For: 2.0.0
>
>
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message