hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15484) Correct the semantic of batch and partial
Date Tue, 07 Mar 2017 10:43:38 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15484?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15899211#comment-15899211
] 

Hudson commented on HBASE-15484:
--------------------------------

SUCCESS: Integrated in Jenkins build HBase-1.4 #657 (See [https://builds.apache.org/job/HBase-1.4/657/])
HBASE-15484 Correct the semantic of batch and partial (yangzhe1991: rev 6afe696e533ad5aaa623ece839c76cbd85ccfb96)
* (edit) hbase-client/src/main/java/org/apache/hadoop/hbase/protobuf/ProtobufUtil.java
* (edit) hbase-client/src/main/java/org/apache/hadoop/hbase/client/ScannerCallableWithReplicas.java
* (edit) hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/RSRpcServices.java
* (edit) hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestScannersFromClientSide2.java
* (edit) hbase-server/src/test/java/org/apache/hadoop/hbase/TestPartialResultsFromClientSide.java
* (edit) hbase-client/src/main/java/org/apache/hadoop/hbase/client/Result.java
* (edit) hbase-client/src/main/java/org/apache/hadoop/hbase/client/ClientScanner.java
* (edit) hbase-client/src/main/java/org/apache/hadoop/hbase/client/ConnectionUtils.java
* (edit) hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/KeyValueScanner.java


> Correct the semantic of batch and partial
> -----------------------------------------
>
>                 Key: HBASE-15484
>                 URL: https://issues.apache.org/jira/browse/HBASE-15484
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Client, scan
>    Affects Versions: 2.0.0, 1.4.0
>            Reporter: Phil Yang
>            Assignee: Phil Yang
>            Priority: Blocker
>             Fix For: 2.0.0, 1.4.0
>
>         Attachments: HBASE-15484.amend.patch, HBASE-15484.branch-1.v01.patch, HBASE-15484.v05.patch,
HBASE-15484.v06.patch, HBASE-15484-v1.patch, HBASE-15484-v2.patch, HBASE-15484-v3.patch, HBASE-15484-v4.patch
>
>
> Follow-up to HBASE-15325, as discussed, the meaning of setBatch and setAllowPartialResults
should not be same. We should not regard setBatch as setAllowPartialResults.
> Now we deprecated isPartial and use mayHaveMoreCellsInRow. If it returns false, current
Result must be the last one of this row.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message