hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15484) Correct the semantic of batch and partial
Date Tue, 07 Mar 2017 06:10:33 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15484?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15898802#comment-15898802
] 

stack commented on HBASE-15484:
-------------------------------

Patch looks great. +1

Would it be good to add this to release note [~yangzhe1991]?

   * If user setBatch(5) and rpc returns 3+5+5+5+3 cells, we should return 5+5+5+5+1 to user.
   * setBatch doesn't mean setAllowPartialResult(true)

hasMoreCellsInRow was never in a release?  Thats why it ok to change the method name?

Want to amend the javadoc on mayHaveMoreCellsInRow method w/ a quick amendment so say you
can't be always sure you are at the end of a row (add in 'may' to fix this bit in javadoc
on the new method... "...True means there are be more cells for the current row....")

Good stuff.

> Correct the semantic of batch and partial
> -----------------------------------------
>
>                 Key: HBASE-15484
>                 URL: https://issues.apache.org/jira/browse/HBASE-15484
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Client, scan
>    Affects Versions: 2.0.0, 1.4.0
>            Reporter: Phil Yang
>            Assignee: Phil Yang
>            Priority: Blocker
>             Fix For: 2.0.0, 1.4.0
>
>         Attachments: HBASE-15484.branch-1.v01.patch, HBASE-15484.v05.patch, HBASE-15484.v06.patch,
HBASE-15484-v1.patch, HBASE-15484-v2.patch, HBASE-15484-v3.patch, HBASE-15484-v4.patch
>
>
> Follow-up to HBASE-15325, as discussed, the meaning of setBatch and setAllowPartialResults
should not be same. We should not regard setBatch as setAllowPartialResults.
> Now we deprecated isPartial and use mayHaveMoreCellsInRow. If it returns false, current
Result must be the last one of this row.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message