hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-17593) Fix build with hadoop 3 profile
Date Fri, 03 Feb 2017 22:29:51 GMT
Appy created HBASE-17593:

             Summary: Fix build with hadoop 3 profile
                 Key: HBASE-17593
                 URL: https://issues.apache.org/jira/browse/HBASE-17593
             Project: HBase
          Issue Type: Bug
            Reporter: Appy
            Assignee: Appy

{{mvn clean install -DskipTests  -Dhadoop-three.version=3.0.0-alpha1 -Dhadoop.profile=3.0}}
fails for me, but passes with {{-Dhadoop-three.version=3.0.0-alpha2}}. The failure with alpha1
is given below.
Haven't investigated the failure, maybe we can simply update the hadoop three version to alpha2?
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.8:run (generate)
on project hbase-server: An Ant BuildException has occured: java.lang.NoSuchMethodError: javax.servlet.ServletContext.getJspConfigDescriptor()Ljavax/servlet/descriptor/JspConfigDescriptor;
[ERROR] around Ant part ...<jspcompiler uriroot="${src.webapps}/master" outputdir="${generated.sources}/java"
package="org.apache.hadoop.hbase.generated.master" webxml="${build.webapps}/master/WEB-INF/web.xml"/>...
@ 17:187 in /Users/appy/apache/hbase/hbase-server/target/antrun/build-main.xml

This message was sent by Atlassian JIRA

View raw message