hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yi Liang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15597) Clean up configuration keys used in hbase-spark module
Date Mon, 13 Feb 2017 18:36:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15597?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15864169#comment-15864169

Yi Liang commented on HBASE-15597:

Hi [~jerryhe]
   I have change the batch and cache related configuration keys to have similar names and
usage as in TableInputFormat, and the from hbase-spark code, it only uses bulkGetSize property
in SQL datasource. The bulkGet rdd has different usage.

> Clean up configuration keys used in hbase-spark module
> ------------------------------------------------------
>                 Key: HBASE-15597
>                 URL: https://issues.apache.org/jira/browse/HBASE-15597
>             Project: HBase
>          Issue Type: Bug
>          Components: spark
>    Affects Versions: 2.0.0
>            Reporter: Sean Busbey
>            Assignee: Yi Liang
>            Priority: Critical
>             Fix For: 2.0.0
>         Attachments: HBASE-15597-v1.patch, HBASE-15597-V2.patch
> This should be considered a blocker for backport to branch-1 since it will impact our
> The constants we expose in configuration should all start with "hbase". Since our configurations
keys for the spark integration all relate to that system, the prefix for all configuration
keys (excluding those cases where we need to do something special due to restrictions in how
properties are handled by e.g. spark) should be "hbase.spark".
> Before publishing a public api labeled version of our spark integration we should review
all of our configuration keys to make sure they either conform to the "hbase.spark" prefix
or they have a comment documenting why they need to be otherwise.

This message was sent by Atlassian JIRA

View raw message