hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Hentschel (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-9702) Change unittests that use "table" or "testtable" to use method names.
Date Mon, 13 Feb 2017 20:14:42 GMT

    [ https://issues.apache.org/jira/browse/HBASE-9702?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15864344#comment-15864344

Jan Hentschel commented on HBASE-9702:

Again, the test failure seems to be unrelated due to a port already in use.

> Change unittests that use "table" or "testtable" to use method names.
> ---------------------------------------------------------------------
>                 Key: HBASE-9702
>                 URL: https://issues.apache.org/jira/browse/HBASE-9702
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Jonathan Hsieh
>            Assignee: Jan Hentschel
>         Attachments: HBASE-9702.master.001.patch, HBASE-9702.master.002.patch
> While working on HBASE-9686, many tests left files that indicated the method they had
come from but several drop data in "table" or "testtable" tables.  Naming them this way makes
it hard to track which tests these came from.  We should make all test use 
> @Rule TestName name = new TestName();
> ...
> TableName  t = TableName.valueOf(name.getMethodName());

This message was sent by Atlassian JIRA

View raw message