hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-9702) Change unittests that use "table" or "testtable" to use method names.
Date Mon, 13 Feb 2017 19:19:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-9702?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15864252#comment-15864252

stack commented on HBASE-9702:

Skimmed RB. It doesn't look like you scripted this but went through all tests. Pretty amazing.
+1 after hadoopqa passes. Thanks for the cleanup [~Jan Hentschel]

> Change unittests that use "table" or "testtable" to use method names.
> ---------------------------------------------------------------------
>                 Key: HBASE-9702
>                 URL: https://issues.apache.org/jira/browse/HBASE-9702
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Jonathan Hsieh
>            Assignee: Jan Hentschel
>         Attachments: HBASE-9702.master.001.patch, HBASE-9702.master.002.patch
> While working on HBASE-9686, many tests left files that indicated the method they had
come from but several drop data in "table" or "testtable" tables.  Naming them this way makes
it hard to track which tests these came from.  We should make all test use 
> @Rule TestName name = new TestName();
> ...
> TableName  t = TableName.valueOf(name.getMethodName());

This message was sent by Atlassian JIRA

View raw message