hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yu Li (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17449) Add explicit document on different timeout settings
Date Wed, 11 Jan 2017 10:42:58 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17449?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15817953#comment-15817953

Yu Li commented on HBASE-17449:

Thanks [~Apache9] for chiming in.

bq. Maybe we could change the name to 'hbase.rpc.scan.timeout'?
I agree, this will make the meaning more clear from property name

bq. In HBASE-17372, I plan to remove the deprecated annotation from hbase.rpc.timeout. It
should be the default rpc timeout config. And we can set read, write, scan or some other operation
specific configs to override the default rpc timeout for the specific operations.
I think this is a good idea.

bq. I do not know the exact meanings of the timeout configs in HBase for the old blocking
implementations... It is totally a mess...
I also felt it confusing... hope we could make things clear after this JIRA, with better document
supplied to user.

Let's wait and see what others will say.

> Add explicit document on different timeout settings
> ---------------------------------------------------
>                 Key: HBASE-17449
>                 URL: https://issues.apache.org/jira/browse/HBASE-17449
>             Project: HBase
>          Issue Type: Improvement
>          Components: documentation
>            Reporter: Yu Li
> Currently we have more than one timeout settings, mainly includes:
> * hbase.rpc.timeout
> * hbase.client.operation.timeout
> * hbase.client.scanner.timeout.period
> And in latest branch-1 or master branch code, we will have two other properties:
> * hbase.rpc.read.timeout
> * hbase.rpc.write.timeout
> However, in current refguid we don't have explicit instruction on the difference of these
timeout settings (there're explanations for each property, but no instruction on when to use
> In my understanding, for RPC layer timeout, or say each rpc call:
> * Scan (openScanner/next): controlled by hbase.client.scanner.timeout.period
> * Other operations:
>    1. For released versions: controlled by hbase.rpc.timeout
>    2. For 1.4+ versions: read operation controlled by hbase.rpc.read.timeout, write operation
controlled by hbase.rpc.write.timeout, or hbase.rpc.timeout if the previous two are not set.
> And hbase.client.operation.timeout is a higher-level control counting retry in, or say
the overall control for one user call.
> After this JIRA, I hope when users ask questions like "What settings I should use if
I don't want to wait for more than 1 second for a single put/get/scan.next call", we could
give a neat answer.

This message was sent by Atlassian JIRA

View raw message