hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17346) Add coprocessor service support
Date Sat, 28 Jan 2017 07:42:25 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15843967#comment-15843967

stack commented on HBASE-17346:

bq.  I'm not sure which one is better.

'callback' is better than 'done' (IMO). 'done' is final. It is what you have when no more
processing to do. I know what is going to happen to the 'callback' param when in an async
context. Just some opinion.

bq. 'whenComplete' is 'CompletableFuture.whenComplete'.

Oh. I missed that. So, 'whenComplete' and then this in this callback, it is 'onComplete'.
That ok you think?

Ok. Thanks for clearning up onComplete vs onRegionComplete... Nothing wrong w/ your english.
I just made one possible reading of what you had written (now I understand better, I can read
your intention). Maybe add the text above as narrative on the pseudo-code.

I skimmed the rest of the patch.  More dumb questions.

First the below looks very nice for client invocation of a endpoint method...

87	    assertEquals(COUNT - 1,
88	      max(TABLE, new LongColumnInterpreter(), new Scan().addColumn(CF, CQ)).get().longValue());

... but how is it working? How does above max invocation become an invocation on the AsyncAggregationClient
max method?

> Add coprocessor service support
> -------------------------------
>                 Key: HBASE-17346
>                 URL: https://issues.apache.org/jira/browse/HBASE-17346
>             Project: HBase
>          Issue Type: Sub-task
>          Components: asyncclient, Client, Coprocessors
>    Affects Versions: 2.0.0
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0
>         Attachments: 17346.suggestion.txt, HBASE-17346.patch, HBASE-17346-v1.patch, HBASE-17346-v2.patch,
> I think we need to redesign the API.

This message was sent by Atlassian JIRA

View raw message