hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Rodionov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-17134) Command line tool: unification of argument names
Date Tue, 22 Nov 2016 20:55:59 GMT

     [ https://issues.apache.org/jira/browse/HBASE-17134?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Vladimir Rodionov updated HBASE-17134:
--------------------------------------
    Attachment: HBASE-17134-v1.patch

v1. cc: [~tedyu@apache.org]

> Command line tool: unification of argument names
> ------------------------------------------------
>
>                 Key: HBASE-17134
>                 URL: https://issues.apache.org/jira/browse/HBASE-17134
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Vladimir Rodionov
>            Assignee: Vladimir Rodionov
>         Attachments: HBASE-17134-v1.patch
>
>
> {quote}
> So, in backup usage, the backup root dir is called backup_root. In restore, it is called
backup_path. I presume these are meant to refer to the same thing?
> In restore, the id for the backup is the backup_id but in describe when I am to pass
a backup id, it is called backupId. Ditto on delete. In the dump of the history, the backup
id is called 'ID'.
> Suggest you use same name for the arg everywhere. The inconsistency makes the tool appear
untrustworthy.
> {quote}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message