hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-17123) Add postBulkLoadHFile variant that notifies the final paths for the hfiles
Date Sat, 19 Nov 2016 01:46:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-17123?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15678349#comment-15678349
] 

Enis Soztutar commented on HBASE-17123:
---------------------------------------

The patch looks good. We want to also deprecate the RegionObserver method in favor of the
previous one. Can you please rename the {{map}} argument to something like {{finalPaths}}
or {{storeFiles}}. Maybe also change familyPaths to {{stagingFamilyPaths}} to make it explicit
that these are paths in the staging directory.   



> Add postBulkLoadHFile variant that notifies the final paths for the hfiles
> --------------------------------------------------------------------------
>
>                 Key: HBASE-17123
>                 URL: https://issues.apache.org/jira/browse/HBASE-17123
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>         Attachments: 17123.v1.txt, 17123.v3.txt, 17123.v4.txt
>
>
> Currently the postBulkLoadHFile() hook passes the same familyPaths parameter which it
receives as method parameter.
> See code in SecureBulkLoadManager :
> {code}
>        loaded = region.getCoprocessorHost().postBulkLoadHFile(familyPaths, loaded);
> {code}
> Meaning, the paths are not final, moved paths of the loaded hfiles.
> This issue is to add a variant which notifies the final paths of the loaded hfiles.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message