hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16945) Implement AsyncRegionLocator
Date Mon, 31 Oct 2016 17:39:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16945?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15622826#comment-15622826
] 

stack commented on HBASE-16945:
-------------------------------

I think it sweet that you no longer have to close down regionlocator.

getDefaultRegionLocation is a bad name for a region locating method (Not your patch -- just
saying) and it has no javadoc on what 'default' means in this case.

Otherwise, patch looks good to me (Is making me study-up on java8ism...)

> Implement AsyncRegionLocator
> ----------------------------
>
>                 Key: HBASE-16945
>                 URL: https://issues.apache.org/jira/browse/HBASE-16945
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Client
>    Affects Versions: 2.0.0
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0
>
>         Attachments: HBASE-16945-v1.patch, HBASE-16945-v2.patch, HBASE-16945.patch
>
>
> Will implement it based on the small scan introduced in HBASE-16932 and the async zk
cluster registry introduced in HBASE-16835.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message