hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16937) Replace SnapshotType protobuf conversion when we can directly use the pojo object
Date Tue, 25 Oct 2016 14:15:58 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16937?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15605423#comment-15605423
] 

Matteo Bertozzi commented on HBASE-16937:
-----------------------------------------

yeah nothing changed. we are still using the non protobuf enum. this patch only removes that
extra conversion protobufToEnum() that we have around since the beginning when we did not
have the pojo object

> Replace SnapshotType protobuf conversion when we can directly use the pojo object
> ---------------------------------------------------------------------------------
>
>                 Key: HBASE-16937
>                 URL: https://issues.apache.org/jira/browse/HBASE-16937
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Matteo Bertozzi
>            Assignee: Matteo Bertozzi
>            Priority: Trivial
>             Fix For: 2.0.0
>
>         Attachments: HBASE-16937-v0.patch, HBASE-16937-v1.patch
>
>
> mostly find & replace work:
> replace the back and forth protobuf conversion when we can just use the client SnapshotType
enum.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message