hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16785) We are not running all tests
Date Fri, 07 Oct 2016 20:41:20 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16785?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15556188#comment-15556188
] 

Matteo Bertozzi commented on HBASE-16785:
-----------------------------------------

patch looks good to me. QA executes the missing test from proc module but then it stops there
since we have the failure

> We are not running all tests
> ----------------------------
>
>                 Key: HBASE-16785
>                 URL: https://issues.apache.org/jira/browse/HBASE-16785
>             Project: HBase
>          Issue Type: Bug
>          Components: build, test
>            Reporter: stack
>            Assignee: stack
>         Attachments: HBASE-16785.master.001.patch
>
>
> Noticed by [~mbertozzi]
> We have some modules where we tried to 'skip' the running of the second part of tests
-- medium and larges. That might have made sense once when the module was originally added
when there may have been just a few small tests to run but as time goes by and the module
accumulates more tests.... in a few cases we've added mediums and larges but we've not removed
the 'skip' config.
> Matteo noticed this happened in hbase-procedure.
> In hbase-client, there is at least a medium test that is being skipped.
> Let me try purging this trick everywhere. It doesn't seem to save us anything going by
build time.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message