hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Heng Chen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16538) Version mismatch in HBaseConfiguration.checkDefaultsVersion
Date Sun, 11 Sep 2016 04:42:21 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16538?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15481021#comment-15481021
] 

Heng Chen commented on HBASE-16538:
-----------------------------------

See compile errors on branch-1,  related ?

{code}
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] /home/jenkins/jenkins-slave/workspace/HBase-1.4/jdk/JDK 1.7 (latest)/label/yahoo-not-h2/hbase-common/src/main/java/org/apache/hadoop/hbase/util/Bytes.java:[49,15]
Unsafe is internal proprietary API and may be removed in a future release
[ERROR] /home/jenkins/jenkins-slave/workspace/HBase-1.4/jdk/JDK 1.7 (latest)/label/yahoo-not-h2/hbase-common/src/main/java/org/apache/hadoop/hbase/util/VersionInfo.java:[26,30]
error: cannot find symbol
[ERROR]   symbol:   class Version
{code}


https://builds.apache.org/job/HBase-1.4/407/jdk=JDK%201.7%20(latest),label=yahoo-not-h2/console

https://builds.apache.org/job/HBase-1.4/407/jdk=JDK%201.8%20(latest),label=yahoo-not-h2/console

> Version mismatch in HBaseConfiguration.checkDefaultsVersion
> -----------------------------------------------------------
>
>                 Key: HBASE-16538
>                 URL: https://issues.apache.org/jira/browse/HBASE-16538
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Appy
>            Assignee: Appy
>              Labels: configuration, test-failure
>             Fix For: 2.0.0, 1.0.4, 1.4.0, 1.2.3, 0.98.22, 1.1.7
>
>         Attachments: HBASE-16538-addendum.patch, HBASE-16538.master.001.patch, HBASE-16538.master.002.patch
>
>
> {noformat}
> org.apache.hadoop.hbase.procedure2.TestYieldProcedures
> testYieldEachExecutionStep(org.apache.hadoop.hbase.procedure2.TestYieldProcedures)  Time
elapsed: 0.255 sec  <<< ERROR!
> java.lang.RuntimeException: hbase-default.xml file seems to be for an older version of
HBase (2.0.0-SNAPSHOT), this version is Unknown
> 	at org.apache.hadoop.hbase.HBaseConfiguration.checkDefaultsVersion(HBaseConfiguration.java:73)
> 	at org.apache.hadoop.hbase.HBaseConfiguration.addHbaseResources(HBaseConfiguration.java:83)
> 	at org.apache.hadoop.hbase.HBaseConfiguration.create(HBaseConfiguration.java:98)
> 	at org.apache.hadoop.hbase.HBaseCommonTestingUtility.<init>(HBaseCommonTestingUtility.java:46)
> 	at org.apache.hadoop.hbase.procedure2.TestYieldProcedures.setUp(TestYieldProcedures.java:63)
> {noformat}
> (Exact test is not important)
> Reference run:
> https://builds.apache.org/view/All/job/HBase-Trunk_matrix/jdk=JDK%201.8%20(latest),label=yahoo-not-h2/1515/console



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message