hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16516) Revisit the implementation of PayloadCarryingRpcController
Date Sat, 03 Sep 2016 17:03:21 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16516?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15461379#comment-15461379
] 

stack commented on HBASE-16516:
-------------------------------

+1 Straight-forward rename with some nice cleanup (I like your doing HRC as an Interface).
Thanks [~Apache9]

> Revisit the implementation of PayloadCarryingRpcController
> ----------------------------------------------------------
>
>                 Key: HBASE-16516
>                 URL: https://issues.apache.org/jira/browse/HBASE-16516
>             Project: HBase
>          Issue Type: Sub-task
>          Components: rpc
>    Affects Versions: 2.0.0
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0
>
>         Attachments: HBASE-16516-v1.patch, HBASE-16516-v2.patch, HBASE-16516-v3.patch,
HBASE-16516-v4.patch, HBASE-16516.patch
>
>
> First, it should be an interface, the current implementation of {{DelegatingPayloadCarryingRpcController}}
is weird.
> Second, we need to be more careful when dealing with cancel.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message