hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Appy (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-16472) TableNotDisabledException when running CREATE from Phoenix
Date Tue, 23 Aug 2016 18:35:21 GMT

     [ https://issues.apache.org/jira/browse/HBASE-16472?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Appy updated HBASE-16472:
-------------------------
    Labels: phoenix  (was: )

> TableNotDisabledException when running CREATE from Phoenix
> ----------------------------------------------------------
>
>                 Key: HBASE-16472
>                 URL: https://issues.apache.org/jira/browse/HBASE-16472
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Dhruv Singhal
>              Labels: phoenix
>
> When I created a table in HBase and then tried running create statement in phoenix. Phoenix
returned me the following error. 
> procedure.ModifyTableProcedure: Error trying to modify table=t21sample state=MODIFY_TABLE_PREPARE
> org.apache.hadoop.hbase.TableNotDisabledException: t21sample
>         at org.apache.hadoop.hbase.master.procedure.ModifyTableProcedure.prepareModify(ModifyTableProcedure.java:298)
>         at org.apache.hadoop.hbase.master.procedure.ModifyTableProcedure.executeFromState(ModifyTableProcedure.java:98)
>         at org.apache.hadoop.hbase.master.procedure.ModifyTableProcedure.executeFromState(ModifyTableProcedure.java:54)
>         at org.apache.hadoop.hbase.procedure2.StateMachineProcedure.execute(StateMachineProcedure.java:107)
>         at org.apache.hadoop.hbase.procedure2.Procedure.doExecute(Procedure.java:400)
>         at org.apache.hadoop.hbase.procedure2.ProcedureExecutor.execProcedure(ProcedureExecutor.java:869)
>         at org.apache.hadoop.hbase.procedure2.ProcedureExecutor.execLoop(ProcedureExecutor.java:673)
>         at org.apache.hadoop.hbase.procedure2.ProcedureExecutor.execLoop(ProcedureExecutor.java:626)
>         at org.apache.hadoop.hbase.procedure2.ProcedureExecutor.access$200(ProcedureExecutor.java:70)
>         at org.apache.hadoop.hbase.procedure2.ProcedureExecutor$1.run(ProcedureExecutor.java:413)
> The same error occurred in the case of altering an existing table. 
> I some how managed to create a table in Phoenix by the same sequence if I disable the
table after creating it. The phoenix returned me table disabled error. But after enabling
the table in hbase, the table was created in phoenix, same worked for alter statement as well.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message