hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16360) TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
Date Wed, 24 Aug 2016 01:22:23 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15434006#comment-15434006
] 

Hudson commented on HBASE-16360:
--------------------------------

SUCCESS: Integrated in Jenkins build HBase-1.2-JDK8 #8 (See [https://builds.apache.org/job/HBase-1.2-JDK8/8/])
HBASE-16360 TableMapReduceUtil addHBaseDependencyJars has the wrong (matteo.bertozzi: rev
71e583df30840e2b4319d850d4647dec262aaada)
* (edit) hbase-server/src/main/java/org/apache/hadoop/hbase/mapreduce/TableMapReduceUtil.java


> TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
> --------------------------------------------------------------------------------------
>
>                 Key: HBASE-16360
>                 URL: https://issues.apache.org/jira/browse/HBASE-16360
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 2.0.0, 1.3.0, 1.0.3, 1.4.0, 1.2.2, 0.98.21
>            Reporter: Matteo Bertozzi
>            Assignee: Jing Pu Chen
>            Priority: Minor
>              Labels: beginner
>             Fix For: 2.0.0, 1.3.0, 1.4.0, 1.2.2, 0.98.22
>
>         Attachments: HBASE-16360-v0.patch
>
>
> HBASE-15152 included the prefix tree module as dependency to TableMapReduceUtil. but
the hardcoded string of the class name is wrong. 
> {code}
> Class.forName("org.apache.hadoop.hbase.code.prefixtree.PrefixTreeCodec");
> {code}
> should be ".codec." instead of ".code."
> {code}
> Class.forName("org.apache.hadoop.hbase.codec.prefixtree.PrefixTreeCodec");
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message