hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-16360) TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
Date Tue, 09 Aug 2016 14:05:21 GMT

     [ https://issues.apache.org/jira/browse/HBASE-16360?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Busbey updated HBASE-16360:
--------------------------------
    Labels: beginner  (was: noob)

> TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
> --------------------------------------------------------------------------------------
>
>                 Key: HBASE-16360
>                 URL: https://issues.apache.org/jira/browse/HBASE-16360
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 2.0.0, 1.3.0, 1.0.3, 1.4.0, 1.2.2
>            Reporter: Matteo Bertozzi
>            Assignee: Jing Pu Chen
>            Priority: Minor
>              Labels: beginner
>             Fix For: 2.0.0, 1.3.0, 1.0.3, 1.4.0, 1.2.2
>
>         Attachments: HBASE-16360-v0.patch
>
>
> HBASE-15152 included the prefix tree module as dependency to TableMapReduceUtil. but
the hardcoded string of the class name is wrong. 
> {code}
> Class.forName("org.apache.hadoop.hbase.code.prefixtree.PrefixTreeCodec");
> {code}
> should be ".codec." instead of ".code."
> {code}
> Class.forName("org.apache.hadoop.hbase.codec.prefixtree.PrefixTreeCodec");
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message