hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16360) TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
Date Fri, 05 Aug 2016 00:06:20 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15408670#comment-15408670
] 

Matteo Bertozzi commented on HBASE-16360:
-----------------------------------------

sure, go ahead.

> TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
> --------------------------------------------------------------------------------------
>
>                 Key: HBASE-16360
>                 URL: https://issues.apache.org/jira/browse/HBASE-16360
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 2.0.0, 1.3.0, 1.0.3, 1.4.0, 1.2.2
>            Reporter: Matteo Bertozzi
>              Labels: noob
>
> HBASE-15152 included the prefix tree module as dependency to TableMapReduceUtil. but
the hardcoded string of the class name is wrong. 
> {code}
> Class.forName("org.apache.hadoop.hbase.code.prefixtree.PrefixTreeCodec");
> {code}
> should be ".codec." instead of ".code."
> {code}
> Class.forName("org.apache.hadoop.hbase.codec.prefixtree.PrefixTreeCodec");
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message