hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-16360) TableMapReduceUtil addHBaseDependencyJars has the wrong class name for PrefixTreeCodec
Date Thu, 04 Aug 2016 23:31:20 GMT
Matteo Bertozzi created HBASE-16360:
---------------------------------------

             Summary: TableMapReduceUtil addHBaseDependencyJars has the wrong class name for
PrefixTreeCodec
                 Key: HBASE-16360
                 URL: https://issues.apache.org/jira/browse/HBASE-16360
             Project: HBase
          Issue Type: Bug
          Components: mapreduce
    Affects Versions: 1.2.2, 1.0.3, 2.0.0, 1.3.0, 1.4.0
            Reporter: Matteo Bertozzi


HBASE-15152 included the prefix tree module as dependency to TableMapReduceUtil. but the hardcoded
string of the class name is wrong. 

{code}
Class.forName("org.apache.hadoop.hbase.code.prefixtree.PrefixTreeCodec");
{code}

should be ".codec." instead of ".code."
{code}
Class.forName("org.apache.hadoop.hbase.codec.prefixtree.PrefixTreeCodec");
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message