hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Ryakhovskiy (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-16230) Calling 'get' in hbase shell with table name that doesn't exist causes it to hang for long time
Date Mon, 18 Jul 2016 15:48:20 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15382481#comment-15382481
] 

Konstantin Ryakhovskiy edited comment on HBASE-16230 at 7/18/16 3:47 PM:
-------------------------------------------------------------------------

[~mantonov], yes, first I have tested that with java api.
I have just made a fresh build out of branch-1.3: mvn -DskipTests package assembly:single
then, started hbase, then hbase-shell, run the command above (get 'table_that_doesnt_exist',
'x') and got following:
{code}
hbase(main):003:0> get 'table_that_doesnt_exist', 'x'
COLUMN                                      CELL                                         
                                                                              

ERROR: Unknown table table_that_doesnt_exist!
{code}
I have also tried to create table, disable and then get -- the same result, exception as expected.
I also tried to drop the table afterwards and execute get and got the same result, exception
as expected.

Still cannot reproduce on branch-1.3.


was (Author: ryakhovskiy.k):
[~mantonov], yes, first I have tested that with java api.
I have just made a fresh build out of branch-1.3: mvn -DskipTests package assembly:single
then, started hbase, then hbase-shell, run the command above (get 'table_that_doesnt_exist',
'x') and got following:

hbase(main):003:0> get 'table_that_doesnt_exist', 'x'
COLUMN                                      CELL                                         
                                                                              

ERROR: Unknown table table_that_doesnt_exist!

I have also tried to create table, disable and then get -- the same result, exception as expected.
I also tried to drop the table afterwards and got the same result, exception as expected.

Still cannot reproduce on branch-1.3.

> Calling 'get' in hbase shell with table name that doesn't exist causes it to hang for
long time
> -----------------------------------------------------------------------------------------------
>
>                 Key: HBASE-16230
>                 URL: https://issues.apache.org/jira/browse/HBASE-16230
>             Project: HBase
>          Issue Type: Bug
>          Components: Client, shell
>    Affects Versions: 1.3.0
>            Reporter: Mikhail Antonov
>
> get 'table_that_doesnt_exist', 'x'
> hangs for duration that looks more like rpc timeout, then says:
> ERROR: HRegionInfo was null in <table name>



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message