hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16196) Update jruby to a newer version.
Date Thu, 07 Jul 2016 22:56:11 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16196?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15366912#comment-15366912
] 

Hadoop QA commented on HBASE-16196:
-----------------------------------

| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} rubocop {color} | {color:blue} 0m 0s {color} | {color:blue}
rubocop was not available. {color} |
| {color:blue}0{color} | {color:blue} ruby-lint {color} | {color:blue} 0m 0s {color} | {color:blue}
Ruby-lint was not available. {color} |
| {color:green}+1{color} | {color:green} @author {color} | {color:green} 0m 0s {color} | {color:green}
The patch does not contain any @author tags. {color} |
| {color:red}-1{color} | {color:red} test4tests {color} | {color:red} 0m 0s {color} | {color:red}
The patch doesn't appear to include any new or modified tests. Please justify why no new tests
are needed for this patch. Also please list what manual steps were performed to verify this
patch. {color} |
| {color:blue}0{color} | {color:blue} mvndep {color} | {color:blue} 0m 13s {color} | {color:blue}
Maven dependency ordering for branch {color} |
| {color:green}+1{color} | {color:green} mvninstall {color} | {color:green} 2m 0s {color}
| {color:green} branch-1 passed {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green} 2m 1s {color} | {color:green}
branch-1 passed with JDK v1.8.0 {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green} 1m 33s {color} |
{color:green} branch-1 passed with JDK v1.7.0_80 {color} |
| {color:green}+1{color} | {color:green} mvneclipse {color} | {color:green} 0m 47s {color}
| {color:green} branch-1 passed {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green} 3m 1s {color} | {color:green}
branch-1 passed with JDK v1.8.0 {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green} 2m 32s {color} |
{color:green} branch-1 passed with JDK v1.7.0_80 {color} |
| {color:blue}0{color} | {color:blue} mvndep {color} | {color:blue} 0m 31s {color} | {color:blue}
Maven dependency ordering for patch {color} |
| {color:red}-1{color} | {color:red} mvninstall {color} | {color:red} 0m 11s {color} | {color:red}
hbase-shell in the patch failed. {color} |
| {color:red}-1{color} | {color:red} mvninstall {color} | {color:red} 1m 41s {color} | {color:red}
root in the patch failed. {color} |
| {color:red}-1{color} | {color:red} compile {color} | {color:red} 0m 21s {color} | {color:red}
hbase-shell in the patch failed with JDK v1.8.0. {color} |
| {color:red}-1{color} | {color:red} compile {color} | {color:red} 1m 21s {color} | {color:red}
root in the patch failed with JDK v1.8.0. {color} |
| {color:red}-1{color} | {color:red} javac {color} | {color:red} 0m 21s {color} | {color:red}
hbase-shell in the patch failed with JDK v1.8.0. {color} |
| {color:red}-1{color} | {color:red} javac {color} | {color:red} 1m 21s {color} | {color:red}
root in the patch failed with JDK v1.8.0. {color} |
| {color:red}-1{color} | {color:red} compile {color} | {color:red} 0m 13s {color} | {color:red}
hbase-shell in the patch failed with JDK v1.7.0_80. {color} |
| {color:red}-1{color} | {color:red} compile {color} | {color:red} 0m 57s {color} | {color:red}
root in the patch failed with JDK v1.7.0_80. {color} |
| {color:red}-1{color} | {color:red} javac {color} | {color:red} 0m 13s {color} | {color:red}
hbase-shell in the patch failed with JDK v1.7.0_80. {color} |
| {color:red}-1{color} | {color:red} javac {color} | {color:red} 0m 57s {color} | {color:red}
root in the patch failed with JDK v1.7.0_80. {color} |
| {color:green}+1{color} | {color:green} mvneclipse {color} | {color:green} 0m 45s {color}
| {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} whitespace {color} | {color:green} 0m 0s {color}
| {color:green} Patch has no whitespace issues. {color} |
| {color:green}+1{color} | {color:green} xml {color} | {color:green} 0m 1s {color} | {color:green}
The patch has no ill-formed XML file. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 1m 41s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.4.0. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 3m 0s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.4.1. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 4m 21s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.5.0. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 5m 38s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.5.1. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 6m 59s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.5.2. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 8m 21s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.6.1. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 9m 41s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.6.2. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 11m 3s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.6.3. {color} |
| {color:red}-1{color} | {color:red} hadoopcheck {color} | {color:red} 12m 23s {color} | {color:red}
Patch causes 14 errors with Hadoop v2.7.1. {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green} 2m 59s {color} |
{color:green} the patch passed with JDK v1.8.0 {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green} 2m 43s {color} |
{color:green} the patch passed with JDK v1.7.0_80 {color} |
| {color:red}-1{color} | {color:red} unit {color} | {color:red} 0m 12s {color} | {color:red}
hbase-shell in the patch failed. {color} |
| {color:red}-1{color} | {color:red} unit {color} | {color:red} 109m 34s {color} | {color:red}
root in the patch failed. {color} |
| {color:green}+1{color} | {color:green} asflicense {color} | {color:green} 0m 31s {color}
| {color:green} Patch does not generate ASF License warnings. {color} |
| {color:black}{color} | {color:black} {color} | {color:black} 146m 51s {color} | {color:black}
{color} |
\\
\\
|| Subsystem || Report/Notes ||
| JIRA Patch URL | https://issues.apache.org/jira/secure/attachment/12816687/hbase-16196.branch-1.patch
|
| JIRA Issue | HBASE-16196 |
| Optional Tests |  asflicense  javac  javadoc  unit  xml  compile  rubocop  ruby_lint  |
| uname | Linux asf900.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep
3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux |
| Build tool | maven |
| Personality | /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/component/dev-support/hbase-personality.sh
|
| git revision | branch-1 / 74090fa |
| Default Java | 1.7.0_80 |
| Multi-JDK versions |  /home/jenkins/tools/java/jdk1.8.0:1.8.0 /home/jenkins/jenkins-slave/tools/hudson.model.JDK/JDK_1.7_latest_:1.7.0_80
|
| mvninstall | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-mvninstall-hbase-shell.txt
|
| mvninstall | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-mvninstall-root.txt
|
| compile | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-hbase-shell-jdk1.8.0.txt
|
| compile | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-root-jdk1.8.0.txt
|
| javac | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-hbase-shell-jdk1.8.0.txt
|
| javac | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-root-jdk1.8.0.txt
|
| compile | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-hbase-shell-jdk1.7.0_80.txt
|
| compile | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-root-jdk1.7.0_80.txt
|
| javac | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-hbase-shell-jdk1.7.0_80.txt
|
| javac | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-compile-root-jdk1.7.0_80.txt
|
| unit | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-unit-hbase-shell.txt
|
| unit | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/artifact/patchprocess/patch-unit-root.txt
|
|  Test Results | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/testReport/ |
| modules | C: hbase-shell . U: . |
| Console output | https://builds.apache.org/job/PreCommit-HBASE-Build/2559/console |
| Powered by | Apache Yetus 0.2.1   http://yetus.apache.org |


This message was automatically generated.



> Update jruby to a newer version.
> --------------------------------
>
>                 Key: HBASE-16196
>                 URL: https://issues.apache.org/jira/browse/HBASE-16196
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Elliott Clark
>            Assignee: Matt Mullins
>         Attachments: 0001-Update-to-JRuby-9.1.2.0-and-JLine-2.12.patch, hbase-16196.branch-1.patch
>
>
> Ruby 1.8.7 is no longer maintained.
> The TTY library in the old jruby is bad. The newer one is less bad.
> Since this is only a dependency on the hbase-shell module and not on hbase-client or
hbase-server this should be a pretty simple thing that doesn't have any backwards compat issues.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message