hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Portabella (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-15925) compat-module maven variable not evaluated
Date Fri, 08 Jul 2016 15:00:14 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15925?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15367785#comment-15367785
] 

David Portabella edited comment on HBASE-15925 at 7/8/16 2:59 PM:
------------------------------------------------------------------

I first reported the problem when running a scala code that depends on hbase version "0.98.7-hadoop2".

Updating this code to use hbase version 1.2.1 (or anything from 1.x to 1.21) fails with:
{code}
Unresolved dependencies path: org.apache.hbase:${compat.module}:1.2.1
{code}

it works now using hbase version 1.2.2.

if you want to try:
{code}
$ git clone https://github.com/dportabella/spark-examples.git
# edit build.sbt:
  replace: val hbaseVersion = "1.2.2"
  add: resolvers += "Apache Staging" at "https://repository.apache.org/content/groups/staging/"

$ rm -Rf /david/.ivy2//cache/org.apache.hbase
$ rm -Rf /david/.m2//repository/org/apache/hbase/
$ sbt run
{code}

So, I don't know why maven does not complain on 1.2.1 (see my post above),
but sbt complains on 1.2.1 and now it works on 1.2.2.
So, I guess the problem is solved. Thanks!



was (Author: dportabella):
I first reported the problem when running a scala code that depends on hbase version "0.98.7-hadoop2".

Updating this code to use hbase version 1.2.1 (or anything from 1.x to 1.21) fails with:
{code}
Unresolved dependencies path: org.apache.hbase:${compat.module}:1.2.1
{code}

it works now using hbase version 1.2.2.

if you want to try:
{code}
$ git clone https://github.com/dportabella/spark-examples.git
# edit build.sbt:
  replace: val hbaseVersion = "1.2.2"
  add: resolvers += "Apache Staging" at "https://repository.apache.org/content/groups/staging/"

$ rm -Rf /Users/david/.ivy2//cache/org.apache.hbase
$ rm -Rf /Users/david/.m2//repository/org/apache/hbase/
$ sbt run
{code}

So, I don't know why maven does not complain on 1.2.1 (see my post above),
but sbt complains on 1.2.1 and now it works on 1.2.2.
So, I guess the problem is solved. Thanks!


> compat-module maven variable not evaluated
> ------------------------------------------
>
>                 Key: HBASE-15925
>                 URL: https://issues.apache.org/jira/browse/HBASE-15925
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.0.0, 1.1.0, 1.2.0, 1.2.1, 1.0.3, 1.1.5
>            Reporter: Nick Dimiduk
>            Assignee: Sean Busbey
>            Priority: Blocker
>             Fix For: 2.0.0, 1.3.0, 1.4.0, 1.2.2, 1.1.6
>
>         Attachments: HBASE-15925.1.patch
>
>
> Looks like we've regressed on HBASE-8488. Have a look at the dependency artifacts list
on http://mvnrepository.com/artifact/org.apache.hbase/hbase-testing-util/1.2.1. Notice the
direct dependency's artifactId is {{$\{compat.module\}}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message