hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Portabella (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15925) compat-module maven variable not evaluated
Date Fri, 08 Jul 2016 14:02:11 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15925?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15367707#comment-15367707
] 

David Portabella commented on HBASE-15925:
------------------------------------------

I no longer understand.
I've tried with 1.2.2 and it works, but now it also works on 1.2.1 from maven central.

I've tried as follows:

{code}
$ mvn archetype:generate -DgroupId=com.example -DartifactId=App -DarchetypeArtifactId=maven-archetype-quickstart
-DinteractiveMode=true
{code}

I've added the hbase-testing-util 1.2.2 dependency and the https://repository.apache.org/content/groups/staging/
repository.

pom.xml
{code}
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>com.example</groupId>
  <artifactId>App</artifactId>
  <packaging>jar</packaging>
  <version>1.0-SNAPSHOT</version>
  <name>App</name>
  <url>http://maven.apache.org</url>

  <dependencies>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.hbase</groupId>
      <artifactId>hbase-testing-util</artifactId>
      <version>1.2.2</version>
    </dependency>
  </dependencies>

  <repositories>
    <repository>
      <id>apache_stage</id>
      <name>Apache Stage</name>
      <url>https://repository.apache.org/content/groups/staging/</url>
    </repository>
  </repositories>
</project>
{code}

And run:
{code}
$ rm -Rf /david/.m2/repository/org/apache/hbase/
$ mvn clean
$ mvn package
$ mvn exec:java -Dexec.mainClass="com.example.App"
{code}

and it works.
however, removing the repository and using 1.2.1 works also now.

I am investigating.


> compat-module maven variable not evaluated
> ------------------------------------------
>
>                 Key: HBASE-15925
>                 URL: https://issues.apache.org/jira/browse/HBASE-15925
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.0.0, 1.1.0, 1.2.0, 1.2.1, 1.0.3, 1.1.5
>            Reporter: Nick Dimiduk
>            Assignee: Sean Busbey
>            Priority: Blocker
>             Fix For: 2.0.0, 1.3.0, 1.4.0, 1.2.2, 1.1.6
>
>         Attachments: HBASE-15925.1.patch
>
>
> Looks like we've regressed on HBASE-8488. Have a look at the dependency artifacts list
on http://mvnrepository.com/artifact/org.apache.hbase/hbase-testing-util/1.2.1. Notice the
direct dependency's artifactId is {{$\{compat.module\}}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message