hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16157) The incorrect block cache count and size are caused by removing duplicate block key in the HBase LruBlockCache
Date Thu, 30 Jun 2016 19:12:10 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16157?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15357668#comment-15357668
] 

Ted Yu commented on HBASE-16157:
--------------------------------

{code}
514	    boolean find = map.remove(block.getCacheKey()) != null;
{code}
nit: name the variable found.
You can use the following annotation for the two helper methods:
{code}
import com.google.common.annotations.VisibleForTesting;
{code}

> The incorrect block cache count and size are caused by removing duplicate block key in
the HBase LruBlockCache
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-16157
>                 URL: https://issues.apache.org/jira/browse/HBASE-16157
>             Project: HBase
>          Issue Type: Bug
>            Reporter: ChiaPing Tsai
>            Priority: Trivial
>         Attachments: HBASE-16157-v1.patch
>
>
> {code:title=LruBlockCache.java|borderStyle=solid}
> // Check return value from the Map#remove before updating the metrics
>   protected long evictBlock(LruCachedBlock block, boolean evictedByEvictionProcess) {
>     map.remove(block.getCacheKey());
>     updateSizeMetrics(block, true);
> ...
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message