hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-16129) check_compatibility.sh is broken when using Java API Compliance Checker v1.7
Date Wed, 29 Jun 2016 19:31:05 GMT

    [ https://issues.apache.org/jira/browse/HBASE-16129?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15355716#comment-15355716
] 

Hudson commented on HBASE-16129:
--------------------------------

FAILURE: Integrated in HBase-Trunk_matrix #1137 (See [https://builds.apache.org/job/HBase-Trunk_matrix/1137/])
HBASE-16129 check_compatibility.sh is broken when using Java API (busbey: rev 294c2dae9e6f6e4323a068de69d0675c8ca80f79)
* dev-support/check_compatibility.sh


> check_compatibility.sh is broken when using Java API Compliance Checker v1.7
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-16129
>                 URL: https://issues.apache.org/jira/browse/HBASE-16129
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>            Reporter: Dima Spivak
>            Assignee: Dima Spivak
>             Fix For: 2.0.0
>
>         Attachments: HBASE-16129_v1.patch, HBASE-16129_v2.patch, HBASE-16129_v3.patch
>
>
> As part of HBASE-16073, we hardcoded check_compatiblity.sh to check out the v1.7 tag
of Java ACC. Unfortunately, just running it between two branches that I know have incompatibilities,
I get 0 incompatibilities (and 0 classes read). Looks like this version doesn't properly traverse
through JARs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message