hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dima Spivak (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-16129) check_compatibility.sh is broken when using Java API Compliance Checker v1.7
Date Mon, 27 Jun 2016 22:38:57 GMT

     [ https://issues.apache.org/jira/browse/HBASE-16129?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dima Spivak updated HBASE-16129:
--------------------------------
    Attachment: HBASE-16129_v1.patch

Adds a {{-j}} / {{\-\-java-acc}} argument, which defaults to 1.6 (the tag of Java ACC that
I've confirmed locally works).

> check_compatibility.sh is broken when using Java API Compliance Checker v1.7
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-16129
>                 URL: https://issues.apache.org/jira/browse/HBASE-16129
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>            Reporter: Dima Spivak
>            Assignee: Dima Spivak
>         Attachments: HBASE-16129_v1.patch
>
>
> As part of HBASE-16073, we hardcoded check_compatiblity.sh to check out the v1.7 tag
of Java ACC. Unfortunately, just running it between two branches that I know have incompatibilities,
I get 0 incompatibilities (and 0 classes read). Looks like this version doesn't properly traverse
through JARs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message