hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sudeep Sunthankar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15893) Get object
Date Tue, 31 May 2016 02:42:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15893?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15307118#comment-15307118
] 

Sudeep Sunthankar commented on HBASE-15893:
-------------------------------------------

Hi Elliott, 
 I have some queries regarding your feedback. Please help me in resolving them.
1) Makefile overcommit
    --- I had created separate branches for Makefile and Get patch. So the Get patch consists
of the source code necessary for Get objects in adddition to the Makefile (which was submitted
in a separate patch). Please let me know if this is the correct way or should I use only one
branch to create the pathces. In this case,  the created patch wont have repeated files.
2) There's no need to have a byte comparable when string already has all that.
    --- We have modelled the classes closely as per the Java API's. So we have created a similar
Bytes class. Please suggest your thoughts on the same
3) hconstants is an abomination and should never ever be repeated.
    --- Motivation for creating hconstants was same as above. If we are doing away with hconstants,
should we define the constants in the separate classes when they are being used ? What if
a constant is required in two separate classes ? 
4) Don't need cell and key value. There's no off heap. We've made no promises about kv's aways
being in the same contiguous memory so there's no need to have the distinction.
    --- Could you please explain this in detail
5) Prefer the protobuf whenever it's api is palatable.
    --- Could you please elaborate this  more. From what I understand, should we make use
of the enums defined in protobuf API's instead of having two separate copies ? Can you give
an example of any other API's ? 
6) B after H is always capital.
    --- Taken care of 
7) Utils is an awful class name
    --- We have changed it to CommonUtils. 

> Get object
> ----------
>
>                 Key: HBASE-15893
>                 URL: https://issues.apache.org/jira/browse/HBASE-15893
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Sudeep Sunthankar
>         Attachments: HBASE-15893.HBASE-14850.v1.patch
>
>
> Patch for creating Get objects.  Get objects can be passed to the Table implementation
to fetch results for a given row. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message