hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15813) Rename DefaultWALProvider to a more specific name and clean up unnecessary reference to it
Date Wed, 11 May 2016 21:50:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15813?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15280884#comment-15280884
] 

stack commented on HBASE-15813:
-------------------------------

bq. What advantage will YA FooUtility have over using the functions in the WALProvider that's
the basis for other FileSystem based WALProviders?

Wind back my suggestion. It not a good one. Ignore. I was reacting to our putting AbstractFSWALProvider
everywhere in this patch; it is kinda ugly having Abstract class as our basis. Got carried
away suggesting we try and put WALProvider Interface in place more instead... but then there
are these little utility methods doing Path operations to find vital info... that are critical
to FSWAL implementations. Also, AbstractFSWALProvider everywhere is an improvemnt on having
DefaultWALProvider throughout.

> Rename DefaultWALProvider to a more specific name and clean up unnecessary reference
to it
> ------------------------------------------------------------------------------------------
>
>                 Key: HBASE-15813
>                 URL: https://issues.apache.org/jira/browse/HBASE-15813
>             Project: HBase
>          Issue Type: Sub-task
>          Components: wal
>    Affects Versions: 2.0.0
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15813.patch
>
>
> This work can be done before we make AsyncFSWAL as our default WAL implementation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message