hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15813) Rename DefaultWALProvider to a more specific name and clean up unnecessary reference to it
Date Wed, 11 May 2016 16:48:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15813?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15280409#comment-15280409
] 

stack commented on HBASE-15813:
-------------------------------

We go from DefaultWALProvider to AbstractFSWALProvider? Pity we can't go to WALProvider?.
We need to be able to get to the utility methods like getServerNameFromWALDirectoryName. Should
we move these  to a utility class in here so we can go to WALProvider or you want to do that
in a followon?

That a bug fix in FanOutOneBlockAsyncDFSOutputHelper.java?



> Rename DefaultWALProvider to a more specific name and clean up unnecessary reference
to it
> ------------------------------------------------------------------------------------------
>
>                 Key: HBASE-15813
>                 URL: https://issues.apache.org/jira/browse/HBASE-15813
>             Project: HBase
>          Issue Type: Sub-task
>          Components: wal
>    Affects Versions: 2.0.0
>            Reporter: Duo Zhang
>            Assignee: Duo Zhang
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15813.patch
>
>
> This work can be done before we make AsyncFSWAL as our default WAL implementation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message