hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matteo Bertozzi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15575) Rename table DDL *Handler methods in MasterObserver to more meaningful names
Date Thu, 05 May 2016 18:19:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15575?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15272777#comment-15272777
] 

Matteo Bertozzi commented on HBASE-15575:
-----------------------------------------

+1 

> Rename table DDL *Handler methods in MasterObserver to more meaningful names
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-15575
>                 URL: https://issues.apache.org/jira/browse/HBASE-15575
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Coprocessors
>    Affects Versions: 2.0.0
>            Reporter: Stephen Yuan Jiang
>            Assignee: Stephen Yuan Jiang
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15575.v1-master.patch, HBASE-15575.v2-master.patch, HBASE-15575.v3-master.patch,
HBASE-15575.v4-master.patch, HBASE-15575.v5-master.patch
>
>
> Procedure V2 replaced table DDL handler implementation to procedure implementation. 
It does not make sense to keep the *Handler methods in MasterObserver.  This JIRA follows
HBASE-13645 way to deprecate the existing observers with *Handler and add the new observers
with more meaningful names.  
> One proposal that to rename the coprocessor in procedure thread with Action and use Completed/Rollback
to distinguish successful or failed procedures.  (Note: this JIRA is just for name change;
the actual Rollback cp does not exist today) 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message