hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15505) ReplicationPeerConfig should be builder-style
Date Fri, 01 Apr 2016 18:22:25 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15222104#comment-15222104

Enis Soztutar commented on HBASE-15505:

bq. PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
It should be named {{ImmutableHTableDescriptor}} to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones? 
We also have {{UnmodifyableHRegionInfo}} which is not used at the moment it seems. 

bq. TestAppend 
This should be already covered in {{TestOperation.testOperationSubClassMethodsAreBuilderStyle}}

You have some issues with indentation in the patch, and the test is failing. 

> ReplicationPeerConfig should be builder-style
> ---------------------------------------------
>                 Key: HBASE-15505
>                 URL: https://issues.apache.org/jira/browse/HBASE-15505
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Enis Soztutar
>            Assignee: Gabor Liptak
>              Labels: beginner, beginners
>             Fix For: 2.0.0
>         Attachments: HBASE-15505.1.patch, HBASE-15505.2.patch, HBASE-15505.3.patch
> Similar to HTD, HCD, {{ReplicationPeerConfig}} should be builder-style: 
> {code}
> ReplicationPeerConfig().setFoo(foo).setBar(bar); 
> {code}
> See {{TestHTableDescriptor.testClassMethodsAreBuilderStyle()}}. 

This message was sent by Atlassian JIRA

View raw message