hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Yang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-15484) Correct the semantic of batch and partial
Date Wed, 06 Apr 2016 16:11:25 GMT

     [ https://issues.apache.org/jira/browse/HBASE-15484?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Phil Yang updated HBASE-15484:
------------------------------
    Attachment: HBASE-15484-v4.patch

Change comment for isPartial.
Change name of some variables and add some comment for understanding the code easier.

Pls review patch-v4 directly, thanks.

> Correct the semantic of batch and partial
> -----------------------------------------
>
>                 Key: HBASE-15484
>                 URL: https://issues.apache.org/jira/browse/HBASE-15484
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 1.2.0, 1.1.3
>            Reporter: Phil Yang
>            Assignee: Phil Yang
>         Attachments: HBASE-15484-v1.patch, HBASE-15484-v2.patch, HBASE-15484-v3.patch,
HBASE-15484-v4.patch
>
>
> Follow-up to HBASE-15325, as discussed, the meaning of setBatch and setAllowPartialResults
should not be same. We should not regard setBatch as setAllowPartialResults.
> And isPartial should be define accurately.
> (Considering getBatch==MaxInt if we don't setBatch.) If result.rawcells.length<scan.getBatch
&& result is not the last part of this row, isPartial==true, otherwise isPartial ==
false. So if user don't setAllowPartialResults(true), isPartial should always be false.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message