hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Yang (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-15484) Correct the semantic of batch and partial
Date Fri, 18 Mar 2016 11:20:33 GMT
Phil Yang created HBASE-15484:

             Summary: Correct the semantic of batch and partial
                 Key: HBASE-15484
                 URL: https://issues.apache.org/jira/browse/HBASE-15484
             Project: HBase
          Issue Type: Bug
    Affects Versions: 1.1.3, 1.2.0
            Reporter: Phil Yang
            Assignee: Phil Yang

Follow-up to HBASE-15325, as discussed, the meaning of setBatch and setAllowPartialResults
should not be same. We should not regard setBatch as setAllowPartialResults.

And isPartial should be define accurately.
(Considering getBatch==MaxInt if we don't setBatch.) If result.rawcells.length<scan.getBatch
&& result is not the last part of this row, isPartial==true, otherwise isPartial ==
false. So if user don't setAllowPartialResults(true), isPartial should always be false.

This message was sent by Atlassian JIRA

View raw message