hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yu Li (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15131) Turn on multi-WAL by default
Date Wed, 20 Jan 2016 03:29:39 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15131?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15107923#comment-15107923
] 

Yu Li commented on HBASE-15131:
-------------------------------

bq. IIRC, the benchmarks from HBASE-14457 used a custom backport on top of 0.98.
You are right [~busbey]. But recently we're preparing to upgrade our cluster to 1.1.2 and
have just done a comparison test between 0.98.12 and 1.1.2 with 4 WALs, the result shows a
matchable performance, JFYI.

And [~eclark] may have more experience of using multiple WAL in facebook. [~eclark] could
you share with us? Many thanks :-)

> Turn on multi-WAL by default
> ----------------------------
>
>                 Key: HBASE-15131
>                 URL: https://issues.apache.org/jira/browse/HBASE-15131
>             Project: HBase
>          Issue Type: New Feature
>          Components: wal
>            Reporter: Enis Soztutar
>             Fix For: 2.0.0, 1.3.0
>
>
> Something to discuss for 2.0 or even 1.3 or 1.4. Should we turn on multi-WAL by default
now that it has seen some production use. 
> Most of the known issues has been fixed I believe for replication, metrics etc. See HBASE-14457.

> Using bounded provider with default 4 (assuming 12 disks). Should we also look at the
number of disks from datanode dirs and auto-configure? 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message