hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Antonov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-15073) Finer grained control over normalization actions for RegionNormalizer
Date Wed, 06 Jan 2016 20:00:42 GMT

    [ https://issues.apache.org/jira/browse/HBASE-15073?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15086182#comment-15086182
] 

Mikhail Antonov commented on HBASE-15073:
-----------------------------------------

Method is still named setNormalizationEnabled on HTD, I'd rename it to setNormalizationMode
(and if getter is there, I'd rename it too). Also references in admin.rb, accordingly. LGTM
otherwise!

> Finer grained control over normalization actions for RegionNormalizer
> ---------------------------------------------------------------------
>
>                 Key: HBASE-15073
>                 URL: https://issues.apache.org/jira/browse/HBASE-15073
>             Project: HBase
>          Issue Type: Task
>          Components: regionserver
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>             Fix For: 2.0.0, 1.2.0, 1.3.0
>
>         Attachments: 15073-v1.txt, 15073-v2.txt, 15073-v2.txt, 15073-v3.txt, 15073-v4.txt
>
>
> Currently both region split and merge actions are carried out during normalization for
underlying table.
> However, for certain use case(s), it would be desirable to perform only one type of action.
> There is one boolean flag, keyed by NORMALIZATION_ENABLED_KEY, per table that enables
normalization.
> To provide finer grained control, we have several options:
> 1. introduce another per table flag to indicate which type(s) of actions are allowed
("N" for disabled, "S" for split only, "M" for merge only and "MS" for both split and merge)
> 2. introduce another global flag to indicate which type(s) of actions are allowed
> 3. modify the meaning of existing flag keyed by NORMALIZATION_ENABLED_KEY so that it
indicates type(s) of actions



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message