hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (HBASE-15059) Allow 0.94 to compile against Hadoop 2.7.x
Date Wed, 13 Jan 2016 16:11:39 GMT

     [ https://issues.apache.org/jira/browse/HBASE-15059?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sean Busbey reopened HBASE-15059:
---------------------------------

reopening, because I don't think this has all the docs needed.

When attempting to build I get a failure from the enforcer plugin because hadoop 2.7 is jdk7+
only:

{{mvn clean site install assembly:single -Prelease -Dhadoop.profile=2.7 -Dlicense.debug.print.included=true}}
(last bit is to avoid license failure while fixing HBASE-14213)
{code}
[INFO] --- maven-enforcer-plugin:1.0.1:enforce (enforce) @ hbase ---
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-common:jar:2.7.1:compile
contains org/apache/hadoop/yarn/lib/package-info.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-api:jar:2.7.1:compile contains
org/apache/hadoop/yarn/api/ApplicationBaseProtocol.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-annotations:jar:2.7.1:compile contains
org/apache/hadoop/classification/InterfaceAudience$LimitedPrivate.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-app:jar:2.7.1:compile
contains org/apache/hadoop/CustomOutputCommitter.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-applicationhistoryservice:jar:2.7.1:compile
contains org/apache/hadoop/yarn/proto/YarnServerTimelineServerRecoveryProtos$1.class targeted
to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-core:jar:2.7.1:compile
contains org/apache/hadoop/filecache/DistributedCache.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet jdk.tools:jdk.tools:jar:1.7:system contains sun/tools/asm/ArrayData.class
targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-common:test-jar:tests:2.7.1:compile
contains org/apache/hadoop/cli/CLITestHelper$TestConfigFileParser.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-hdfs:jar:2.7.1:compile contains
org/apache/hadoop/fs/BlockStorageLocation.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-nodemanager:jar:2.7.1:compile
contains org/apache/hadoop/yarn/proto/LocalizationProtocol$1.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-common:jar:2.7.1:compile
contains org/apache/hadoop/mapred/LocalClientProtocolProvider.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-resourcemanager:jar:2.7.1:compile
contains org/apache/hadoop/yarn/proto/YarnSecurityTestClientAMTokenProtos$1.class targeted
to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-jobclient:jar:2.7.1:compile
contains org/apache/hadoop/mapred/ClientCache$1.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-shuffle:jar:2.7.1:compile
contains org/apache/hadoop/mapred/FadvisedChunkedFile.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-hdfs:test-jar:tests:2.7.1:compile
contains org/apache/hadoop/cli/CLITestCmdDFS.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-jobclient:test-jar:tests:2.7.1:compile
contains org/apache/hadoop/cli/CLITestCmdMR.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-web-proxy:jar:2.7.1:compile
contains org/apache/hadoop/yarn/server/webproxy/amfilter/AmFilterInitializer.class targeted
to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-common:jar:2.7.1:compile contains
org/apache/hadoop/conf/Configurable.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-mapreduce-client-hs:jar:2.7.1:compile
contains org/apache/hadoop/mapreduce/v2/hs/CachedHistoryStorage$1.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-auth:jar:2.7.1:compile contains
org/apache/hadoop/security/authentication/client/AuthenticatedURL$Token.class targeted to
JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-server-tests:test-jar:tests:2.7.1:compile
contains org/apache/hadoop/yarn/server/ContainerTokenIdentifierForTest.class targeted to JDK
1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-client:jar:2.7.1:compile contains
org/apache/hadoop/yarn/client/api/AHSClient.class targeted to JDK 1.7
[INFO] Restricted to JDK 1.6 yet org.apache.hadoop:hadoop-yarn-common:jar:2.7.1:compile contains
org/apache/hadoop/yarn/api/ApplicationClientProtocolPB.class targeted to JDK 1.7
[WARNING] Rule 0: org.apache.maven.plugins.enforcer.EnforceBytecodeVersion failed with message:
HBase has unsupported dependencies.
  HBase requires that all dependencies be compiled with version 1.6 or earlier
  of the JDK to properly build from source.  You appear to be using a newer dependency. You
can use
  either "mvn -version" or "mvn enforcer:display-info" to verify what version is active.
  Non-release builds can temporarily build with a newer JDK version by setting the
  'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
{code}

I think the instructions should include setting the {{compileSource}} property.

> Allow 0.94 to compile against Hadoop 2.7.x
> ------------------------------------------
>
>                 Key: HBASE-15059
>                 URL: https://issues.apache.org/jira/browse/HBASE-15059
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>             Fix For: 0.94.28
>
>         Attachments: 15059-v2.txt, 15059.txt
>
>
> Currently HBase 0.94 cannot be compiled against Hadoop 2.7.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message